Luscii - Priority 2: Patient information blocks duplicated when switching protocols – Incident details

All systems operational

Priority 2: Patient information blocks duplicated when switching protocols

Monitoring
Degraded performance
Started 2 days ago

Affected

Luscii Web App

Degraded performance from 3:16 PM to 10:16 AM, Operational from 10:16 AM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    Update: The hotfix has been released and the issue can no longer occur. We’re working on a solution for the already duplicated information blocks.

  • Identified
    Identified

    Update: Tomorrow we will release a fix to prevent this issue from happening again. A separate fix is still needed for the already duplicated information blocks.

  • Investigating
    Investigating

    Situation: We have discovered an issue where patient information blocks are duplicated when switching protocols within the same program. In some cases, editing these duplicated information blocks causes personalized information to not be displayed correctly to patients.

    Complication: These duplicates are visible in the web version (not to patients in the mobile app), but can be personalized. In specific cases, this results in missing personalized information for patients.

    Next steps: We are investigating this issue with high urgency. Updates will follow as more becomes known.